summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-02-17 19:07:49 +0000
committerMorgan Deters <mdeters@gmail.com>2010-02-17 19:07:49 +0000
commit2dadba52dd55084bbec52b3b338add5f8be77c13 (patch)
tree865ef94f3cda0d4bd465edd91a9c375d42ac660c /configure.ac
parent421446830d238e4a82fb0407621b2876b6e46a74 (diff)
fix bug 27: --with-cxxtest-dir=(relative-path) now works
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7b27b8b6f..247aceb92 100644
--- a/configure.ac
+++ b/configure.ac
@@ -331,6 +331,16 @@ AC_ARG_WITH([cxxtest-dir],
[AS_HELP_STRING([--with-cxxtest-dir=DIR], [path to CxxTest installation])],
[CXXTEST="$withval"])
+# In the case of "./configure --with-cxxtest-dir=../cxxtest" (or other
+# relative path) and having switched the configure directory (see above),
+# search with respect to the top source dir, not the build dir
+if test "$CVC4_CONFIGURE_IN_BUILDS" = yes; then
+ case "$CXXTEST" in
+ /*) ;;
+ *) CXXTEST="$srcdir/$CXXTEST" ;;
+ esac
+fi
+
CXXTESTGEN=
AC_PATH_PROG(CXXTESTGEN, cxxtestgen.pl, [], [$CXXTEST:$PATH])
if test -z "$CXXTESTGEN"; then
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback