summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@cs.nyu.edu>2013-12-09 18:31:17 -0500
committerMorgan Deters <mdeters@cs.nyu.edu>2013-12-10 23:26:50 -0500
commita1303ece0eb375b89080036eea1837835d6fd3a8 (patch)
treeb97a35d76cc7915c24930a5f8c5fabe9221bbdbb /configure.ac
parenta44de9d1d303f78b7abcb1ecb199899491191208 (diff)
GLPK build identifier, license warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f1fd797a0..89d59cfff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,7 +112,7 @@ AC_ARG_WITH([build],
if test -z "${with_build+set}" -o "$with_build" = default; then
with_build=default
fi
-if test -z "${enable_optimized+set}" -a -z "${enable_debug_symbols+set}" -a -z "${enable_assertions+set}" -a -z "${enable_tracing+set}" -a -z "${enable_dumping+set}" -a -z "${enable_muzzle+set}" -a -z "${enable_coverage+set}" -a -z "${enable_profiling+set}" -a -z "${enable_statistics+set}" -a -z "${enable_replay+set}" -a -z "${with_gmp+set}" -a -z "${with_cln+set}"; then
+if test -z "${enable_optimized+set}" -a -z "${enable_debug_symbols+set}" -a -z "${enable_assertions+set}" -a -z "${enable_tracing+set}" -a -z "${enable_dumping+set}" -a -z "${enable_muzzle+set}" -a -z "${enable_coverage+set}" -a -z "${enable_profiling+set}" -a -z "${enable_statistics+set}" -a -z "${enable_replay+set}" -a -z "${with_gmp+set}" -a -z "${with_cln+set}" -a -z "${with_glpk+set}"; then
custom_build_profile=no
else
custom_build_profile=yes
@@ -202,6 +202,11 @@ if test -n "${enable_replay+set}"; then
btargs="$btargs noreplay"
fi
fi
+if test -n "${with_glpk+set}"; then
+ if test "$with_glpk" = yes; then
+ btargs="$btargs glpk"
+ fi
+fi
AC_MSG_RESULT([$with_build])
AM_INIT_AUTOMAKE([1.11 no-define tar-pax parallel-tests color-tests subdir-objects])
@@ -1321,6 +1326,17 @@ else
optimized="no"
fi
+if test $have_libglpk -eq 1; then
+ licensewarn="${licensewarn}Please note that CVC4 will be built against the GNU Linear Programming
+Kit (GLPK). This library is covered under the GPL, so use of this build
+of CVC4 will be more restrictive than CVC4's license would normally
+suggest. For full details of GLPK and its license, please visit
+ http://www.gnu.org/software/glpk/
+To build CVC4 without GLPK, configure --without-glpk (which is the default).
+
+"
+fi
+
if test $cvc4_cln_or_gmp = cln; then
mplibrary='cln (GPL)'
licensewarn="${licensewarn}Please note that CVC4 will be built against the Class Library for
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback