summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2011-09-16 20:19:25 +0000
committerMorgan Deters <mdeters@gmail.com>2011-09-16 20:19:25 +0000
commitf613825ab12e049b88833ad15773217e7310cf07 (patch)
treebd7f1fc0064335354565e338717ff78162ea1be1 /configure.ac
parent1f8c6509afb1d7d99f2e4c0ef2df91b25be31bec (diff)
fix debian build without breaking anything (i hope)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index fdacfeb7f..3205d9a3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,7 +53,7 @@ CVC4_BINDINGS_LIBRARY_VERSION=0:0:0
# we save it. (We can't do our build profile stuff here, or it's not
# included in the output... autoconf overrides us on the orderings of
# some things.)
-config_cmdline="$@"
+config_cmdline=("$@")
# remember if the user set these explicitly (or whether autoconf does)
user_specified_enable_or_disable_static=${enable_static+yes}
@@ -310,8 +310,8 @@ elif test "$CVC4_CONFIGURE_AT_TOP_LEVEL" = yes; then
$as_echo "cd builds/$target/$build_type"
cd "builds/$target/$build_type"
CVC4_CONFIGURE_IN_BUILDS=yes; export CVC4_CONFIGURE_IN_BUILDS
- $as_echo "../../../configure $config_cmdline"
- `pwd`/../../../configure $config_cmdline
+ echo "../../../configure ${config_cmdline[[@]]}"
+ `pwd`/../../../configure "${config_cmdline[[@]]}"
exitval=$?
cd ../../..
if test $exitval -eq 0; then
@@ -831,6 +831,9 @@ AC_SUBST(STATIC_BINARY)
AM_CONDITIONAL([STATIC_BINARY], [test "$enable_static_binary" = yes])
AM_CONDITIONAL([COVERAGE_ENABLED], [test "$enable_coverage" = yes])
+AM_CONDITIONAL([CVC4_DEBUG], [test "$with_build" = debug])
+AM_CONDITIONAL([CVC4_TRACING], [test "$enable_tracing" = yes])
+
AC_SUBST(CVC4_LIBRARY_VERSION)
AC_SUBST(CVC4_PARSER_LIBRARY_VERSION)
AC_SUBST(CVC4_COMPAT_LIBRARY_VERSION)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback