summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@cs.nyu.edu>2013-04-29 10:50:43 -0400
committerMorgan Deters <mdeters@cs.nyu.edu>2013-04-29 12:11:41 -0400
commitbb32f230b1bf822a422efe89f35ac92c8d17c50f (patch)
tree34ed1ddaf1660691fed58900f837b7f676fb3fca /configure.ac
parentd0514a37c2bf753ae5da35b2c350f2d681f9a752 (diff)
Fixes to FCSimplex for some versions of compilers
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index deee4fa68..ca868c0d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -751,6 +751,21 @@ void foo(int64_t) {}])],
AC_LANG_POP([C++])
AC_SUBST([CVC4_NEED_INT64_T_OVERLOADS])
+AC_MSG_CHECKING([for the pb_ds namespace])
+AC_LANG_PUSH([C++])
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+#include <ext/pb_ds/priority_queue.hpp>
+typedef pb_ds::priority_queue<void, void, void> pq;])],
+ [CVC4_PB_DS_NAMESPACE=pb_ds],
+ [AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+ #include <ext/pb_ds/priority_queue.hpp>
+ typedef __gnu_pbds::priority_queue<void, void, void> pq;])],
+ [CVC4_PB_DS_NAMESPACE=__gnu_pbds],
+ [AC_MSG_ERROR([can't find required priority_queue in either __gnu_pbds or pb_ds namespace])])])
+AC_LANG_POP([C++])
+AC_DEFINE_UNQUOTED(CVC4_PB_DS_NAMESPACE, ${CVC4_PB_DS_NAMESPACE}, [The namespace for pb_ds data structures.])
+AC_MSG_RESULT([$CVC4_PB_DS_NAMESPACE])
+
# Check for ANTLR runantlr script (defined in config/antlr.m4)
AC_PROG_ANTLR
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback