summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-10-24 22:24:34 +0000
committerMorgan Deters <mdeters@gmail.com>2012-10-24 22:24:34 +0000
commit9c6f99513f27404fdd596217f3a438aee155851e (patch)
treed0da998e9f7fc72141a0db6ab3af18962afa1c3c /configure.ac
parenta6ac7fefed613c4d83e577361f98c28a8e18f3a9 (diff)
Includes many fixes to build system for Solaris (thanks Tim!), and also
just in general, and some documentation adjustments.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5e4d3a371..f94f07419 100644
--- a/configure.ac
+++ b/configure.ac
@@ -379,6 +379,7 @@ echo ./config.status "\$@"
EOF
chmod +x config.reconfig
fi
+ ln -sf "builds/$target/$build_type/config.log" "config.log"
exit $exitval
else
AC_MSG_RESULT([this one (user-specified)])
@@ -929,7 +930,7 @@ if test "$enable_thread_support" = no; then
fi
else
BOOST_THREADS([], [AC_MSG_WARN([disabling multithreaded support])
- cvc4_has_threads=no])
+ cvc4_has_threads=no])
fi
LDFLAGS="$cvc4_save_LDFLAGS"
if test $cvc4_has_threads = no; then
@@ -1129,6 +1130,8 @@ else
AC_SUBST([CVC4_HAS_THREADS], 0)
fi
+AM_CONDITIONAL([CVC4_NEEDS_REPLACEMENT_FUNCTIONS], [test -n "$LTLIBOBJS"])
+
CVC4_CONFIG_FILE_ONLY_IF_CHANGED([src/util/rational.h])
CVC4_CONFIG_FILE_ONLY_IF_CHANGED([src/util/integer.h])
CVC4_CONFIG_FILE_ONLY_IF_CHANGED([src/util/tls.h])
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback