summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-11-05 22:53:04 +0000
committerMorgan Deters <mdeters@gmail.com>2012-11-05 22:53:04 +0000
commit0c70f77d75ba206e572fa0c91cbb2d8773a6a8db (patch)
treeed5af342a1ef217aae12aac9b67c0e7c850664fd /configure.ac
parentc48729f90e752425bb46c99e3becd59eeca1daaf (diff)
fixes for mac os
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2c67be865..940ad43d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -482,7 +482,12 @@ fi
AC_MSG_RESULT([$enable_static_binary])
if test "$enable_static_binary" = yes; then
if test "$target_vendor" = apple; then
- AC_MSG_ERROR([[Statically-linked binaries are not supported on Mac OS. See https://developer.apple.com/library/mac/#qa/qa2001/qa1118.html]])
+ if test -z "$MAC_STATIC_BINARY_MANUAL_OVERRIDE"; then
+ AC_MSG_ERROR([[Statically-linked binaries are not supported on Mac OS. See https://developer.apple.com/library/mac/#qa/qa2001/qa1118.html . (If you ABSOLUTELY insist on this going forward and you know what you are doing, set MAC_STATIC_BINARY_MANUAL_OVERRIDE=1)]])
+ else
+ AC_MSG_WARN([MAC_STATIC_BINARY_MANUAL_OVERRIDE was set!])
+ AC_MSG_WARN([Will make a static binary during this build. Note that it may fail!])
+ fi
fi
if test "$enable_static" != yes; then
enable_static=yes
@@ -1135,7 +1140,7 @@ else
AC_SUBST([CVC4_HAS_THREADS], 0)
fi
-AM_CONDITIONAL([CVC4_NEEDS_REPLACEMENT_FUNCTIONS], [test -n "$LTLIBOBJS"])
+AM_CONDITIONAL([CVC4_NEEDS_REPLACEMENT_FUNCTIONS], [test -n "$LIBOBJS"])
CVC4_CONFIG_FILE_ONLY_IF_CHANGED([src/util/rational.h])
CVC4_CONFIG_FILE_ONLY_IF_CHANGED([src/util/integer.h])
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback