summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@cs.nyu.edu>2013-08-05 18:29:34 -0400
committerMorgan Deters <mdeters@cs.nyu.edu>2013-12-23 13:21:47 -0500
commitff7d33c2f75668fde0f149943e3cf1bedad1102f (patch)
treeb2533c2a7bf09602d567379ea1dc3bacc9f059c3 /Makefile.am
parentb2bb2138543e75f64c3a794df940a221e4b5a97b (diff)
Proof-checking code; fixups of segfaults and missing functionality in proof generation; fix bug 285.
* segfaults/assert-fails in proof-generation fixed, including bug 285 * added --check-proofs to automatically check proofs, like --check-models (but only for UF/SAT at present) * proof generation now works in portfolio (but *not* --check-proofs, since LFSC code uses globals) * proofs are *not* yet supported in incremental mode * added --dump-proofs to dump out proofs, like --dump-models * run_regression script now runs with --check-proofs where appropriate * options scripts now support :link-smt for SMT options, like :link for command-line
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 40f4c7006..55c357def 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,11 +7,11 @@ ACLOCAL_AMFLAGS = -I config
SUBDIRS_BASE = src test contrib
if CVC4_PROOF
- SUBDIRS = proofs/lfsc_checker $(SUBDIRS_BASE)
+ SUBDIRS = proofs/signatures proofs/lfsc_checker $(SUBDIRS_BASE)
else
SUBDIRS = $(SUBDIRS_BASE)
endif
-DIST_SUBDIRS = proofs/lfsc_checker $(SUBDIRS_BASE) examples
+DIST_SUBDIRS = proofs/signatures proofs/lfsc_checker $(SUBDIRS_BASE) examples
.PHONY: examples
examples: all
@@ -130,11 +130,7 @@ EXTRA_DIST = \
doc/SmtEngine.3cvc_template.in \
doc/options.3cvc_template.in \
doc/libcvc4parser.3.in \
- doc/libcvc4compat.3.in \
- proofs/signatures/example.plf \
- proofs/signatures/sat.plf \
- proofs/signatures/smt.plf \
- proofs/signatures/th_base.plf
+ doc/libcvc4compat.3.in
man_MANS = \
doc/cvc4.1 \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback