summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@cs.nyu.edu>2013-12-12 18:24:54 -0500
committerMorgan Deters <mdeters@cs.nyu.edu>2013-12-16 22:28:26 -0500
commit5186ca79710fe935d1f7ed27c4a34e913ab547e8 (patch)
tree4f5ce4957063085f607492a6474b0d244e4b2da4 /Makefile.am
parent4d9caf9782c59823fb95519b9b518b7d7f89738a (diff)
First attempt at incorporating LFSC proof checker into CVC4.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 41586cbe7..40f4c7006 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,8 +5,13 @@ AM_CXXFLAGS = -Wall -Wno-unknown-pragmas
AUTOMAKE_OPTIONS = foreign
ACLOCAL_AMFLAGS = -I config
-SUBDIRS = src test contrib
-DIST_SUBDIRS = $(SUBDIRS) examples
+SUBDIRS_BASE = src test contrib
+if CVC4_PROOF
+ SUBDIRS = proofs/lfsc_checker $(SUBDIRS_BASE)
+else
+ SUBDIRS = $(SUBDIRS_BASE)
+endif
+DIST_SUBDIRS = proofs/lfsc_checker $(SUBDIRS_BASE) examples
.PHONY: examples
examples: all
@@ -125,7 +130,12 @@ EXTRA_DIST = \
doc/SmtEngine.3cvc_template.in \
doc/options.3cvc_template.in \
doc/libcvc4parser.3.in \
- doc/libcvc4compat.3.in
+ doc/libcvc4compat.3.in \
+ proofs/signatures/example.plf \
+ proofs/signatures/sat.plf \
+ proofs/signatures/smt.plf \
+ proofs/signatures/th_base.plf
+
man_MANS = \
doc/cvc4.1 \
doc/pcvc4.1 \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback