summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-07-04 02:00:42 +0000
committerMorgan Deters <mdeters@gmail.com>2010-07-04 02:00:42 +0000
commitcc726b5080f8926a3cb96a1b9d1098ad8725ab86 (patch)
treee27572b69cefa5cbc2addb6e19c0c5a13e402746 /Makefile.am
parent33f1138d8ab09bf133b945647d9239befe297d5e (diff)
make dist && make distcheck functional, other fixes
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4048b1b41..35744e381 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,3 +80,21 @@ lcov lcov-all lcov18:
endif
+# abs_srcdir is required here to get this Makefile instead of the
+# Makefile in the builddir (since $(srcdir) is stripped off of
+# EXTRA_DIST files)
+EXTRA_DIST = \
+ Makefile.builds.in \
+ Makefile.subdir \
+ config/build-type \
+ config/mkbuilddir \
+ contrib/addsourcedir \
+ contrib/code-checker \
+ contrib/configure-in-place \
+ contrib/cvc-devel.el \
+ contrib/cvc-mode.el \
+ contrib/dimacs_to_smt.pl \
+ contrib/editing-with-emacs \
+ contrib/switch-config
+dist-hook:
+ cp -p "$(srcdir)/Makefile" "$(distdir)/Makefile"
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback