summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew V. Jones <andrew.jones@vector.com>2020-09-17 08:18:43 +0100
committerGitHub <noreply@github.com>2020-09-17 09:18:43 +0200
commitad4f264cbab0236607534ecd3414ebd8a36b69e6 (patch)
tree6220b1f2868ae35e9530355554dc45dfc9921242 /CMakeLists.txt
parent169a281ca849b7c9fcf61d9ece0c46f728a44cc2 (diff)
Do not allow to build Python bindings if building statically (#4784)
This PR disables building the Python bindings if you're doing a static build (which makes sense, because there's no such thing as a "static" Python module). Signed-off-by: Andrew V. Jones andrew.jones@vector.com
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a4b5aea4..849adf704 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -328,6 +328,11 @@ else()
message(WARNING "Disabling unit tests since static build is enabled.")
set(ENABLE_UNIT_TESTING OFF)
endif()
+
+ if (BUILD_BINDINGS_PYTHON)
+ message(FATAL_ERROR "Building Python bindings is not possible "
+ "when building statically")
+ endif()
endif()
#-----------------------------------------------------------------------------#
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback