summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-10-02 11:52:06 -0700
committerAina Niemetz <aina.niemetz@gmail.com>2018-10-02 11:52:06 -0700
commit1300320d84e89306ce988bd3cbe2b12f0fc6b8a5 (patch)
tree4807dd0867b40249823b0a630282e2ad4b1c1e97 /CMakeLists.txt
parent8519233cec9501f31aa1789eff60cb802c8df450 (diff)
cmake: Add examples to build-tests, add warning for disabling static build. (#2562)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e850f9928..435407fea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -196,6 +196,9 @@ endif()
# Never build unit tests as static binaries, otherwise we'll end up with
# ~300MB per unit test.
if(ENABLE_UNIT_TESTING)
+ if(NOT ENABLE_SHARED)
+ message(WARNING "Disabling static build since unit testing is enabled.")
+ endif()
set(ENABLE_SHARED ON)
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback