summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2021-02-24 16:26:44 -0800
committerGitHub <noreply@github.com>2021-02-24 16:26:44 -0800
commite36aeda0e759c5328ba76412dde8afbecf34970b (patch)
tree47f6795c587710c78cc558abbb3576f397c7e3b7 /CMakeLists.txt
parentc3e16e447aed037806f874a54ae74d6850415fd7 (diff)
Enable -Werror. (#5969)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3dd282a8d..c32c10f4d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -234,8 +234,9 @@ include(Config${CMAKE_BUILD_TYPE})
add_check_c_cxx_flag("-O${OPTIMIZATION_LEVEL}")
add_check_c_cxx_flag("-Wall")
+add_check_c_cxx_flag("-Werror")
+add_check_c_cxx_flag("-Wno-unused-private-field")
add_check_c_flag("-fexceptions")
-add_check_c_cxx_flag("-Wno-deprecated")
add_check_cxx_flag("-Wsuggest-override")
add_check_cxx_flag("-Wnon-virtual-dtor")
add_check_c_cxx_flag("-Wimplicit-fallthrough")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback