summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2021-03-16 13:30:21 -0700
committerGitHub <noreply@github.com>2021-03-16 20:30:21 +0000
commit4587d4000e2544765ce940c4bd3bcaec42ca6507 (patch)
tree958122d68cbee79760e644dd1979f9719244c9ba /CMakeLists.txt
parent8c1138f4a076acdabae18bf3d6d088ac1ab10587 (diff)
ci: Enable checking of proofs + unsat cores. (#6088)
This commit refactors the run_regression.py script and adds options for enabling/disabling checking of proofs and unsat cores. Both options are enabled by default and disabled for each corresponding CI build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c06c360ac..843fc16c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -430,7 +430,6 @@ if(ENABLE_PROFILING)
endif()
if(ENABLE_PROOFS)
- set(RUN_REGRESSION_ARGS ${RUN_REGRESSION_ARGS} --enable-proof)
add_definitions(-DCVC4_PROOF)
endif()
@@ -495,7 +494,6 @@ if(USE_KISSAT)
endif()
if(USE_LFSC)
- set(RUN_REGRESSION_ARGS ${RUN_REGRESSION_ARGS} --with-lfsc)
find_package(LFSC REQUIRED)
add_definitions(-DCVC4_USE_LFSC)
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback