summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2021-04-22 13:22:36 -0700
committerGitHub <noreply@github.com>2021-04-22 20:22:36 +0000
commit2aab6ea4c8455f80a2bb08bc88fdb919a79a010f (patch)
treef13574eb6a57cb8be480904d404dc5f937ce40a9 /CMakeLists.txt
parentc84d66ed370f417bd410c3c7ae5c1db82e637452 (diff)
cmake: Do not require --auto-download for already downloaded dependencies. (#6417)
This will look for already downloaded dependencies in the build directory and therefore will not require --auto-download if the dependencies were already downloaded in a previous build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77f9fb566..1c6ad1604 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -247,7 +247,7 @@ endif()
# Only enable unit testing if assertions are enabled. Otherwise, unit tests
# that expect AssertionException to be thrown will fail.
if(NOT ENABLE_ASSERTIONS)
- message(WARNING "Disabling unit tests since assertions are disabled.")
+ message(STATUS "Disabling unit tests since assertions are disabled.")
set(ENABLE_UNIT_TESTING OFF)
endif()
@@ -261,7 +261,7 @@ if(ENABLE_SHARED)
set(BUILD_SHARED_LIBS ON)
if(ENABLE_STATIC_BINARY)
set(ENABLE_STATIC_BINARY OFF)
- message(WARNING "Disabling static binary since shared build is enabled.")
+ message(STATUS "Disabling static binary since shared build is enabled.")
endif()
# Set visibility to default if unit tests are enabled
@@ -300,7 +300,7 @@ else()
# Never build unit tests as static binaries, otherwise we'll end up with
# ~300MB per unit test.
if(ENABLE_UNIT_TESTING)
- message(WARNING "Disabling unit tests since static build is enabled.")
+ message(STATUS "Disabling unit tests since static build is enabled.")
set(ENABLE_UNIT_TESTING OFF)
endif()
@@ -439,7 +439,7 @@ if(USE_CRYPTOMINISAT)
if(THREADS_HAVE_PTHREAD_ARG)
add_c_cxx_flag(-pthread)
endif()
- find_package(CryptoMiniSat REQUIRED)
+ find_package(CryptoMiniSat 5.8 REQUIRED)
add_definitions(-DCVC5_USE_CRYPTOMINISAT)
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback