summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-09-27 19:47:25 -0700
committerGitHub <noreply@github.com>2018-09-27 19:47:25 -0700
commitf939b41b2710ea2020a646b2f1a018fb9c78ff8c (patch)
treed3e11538a1783daa896b54fb102b2467b6f3f77d /CMakeLists.txt
parent4a9e21371a5012285114126cab1dbce18fdcec6c (diff)
cmake: Add CxxTest finder module to allow custom paths. (#2542)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 654e5f3f2..86007b39a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -90,6 +90,7 @@ set(ABC_DIR "" CACHE STRING "Set ABC install directory")
set(ANTLR_DIR "" CACHE STRING "Set ANTLR3 install directory")
set(CADICAL_DIR "" CACHE STRING "Set CaDiCaL install directory")
set(CRYPTOMINISAT_DIR "" CACHE STRING "Set CryptoMiniSat install directory")
+set(CXXTEST_DIR "" CACHE STRING "Set CxxTest install directory")
set(GLPK_DIR "" CACHE STRING "Set GLPK install directory")
set(GMP_DIR "" CACHE STRING "Set GMP install directory")
set(LFSC_DIR "" CACHE STRING "Set LFSC install directory")
@@ -330,10 +331,6 @@ if(ENABLE_TRACING)
add_definitions(-DCVC4_TRACING)
endif()
-if(ENABLE_UNIT_TESTING)
- find_package(CxxTest REQUIRED)
-endif()
-
if(ENABLE_STATISTICS)
add_definitions(-DCVC4_STATISTICS_ON)
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback