summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2020-10-05 16:14:10 -0700
committerGitHub <noreply@github.com>2020-10-05 16:14:10 -0700
commit88fb54a554f1a374a380b1808d355f096437d1c0 (patch)
tree70e3a56c22fa5afaee520b3422f64d506506cf5d /CMakeLists.txt
parente65308fa102d7121a981c9e6bc5b1414b28f9b28 (diff)
cmake: Add warning when unit testing is disabled due to assertions being disabled. (#5204)
This further fixes the testing instructions for API tests (formerly known as system tests) in INSTALL.md. Co-authored-by: Haniel Barbosa <hanielbbarbosa@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b4b298ff..8eab22e4a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -289,6 +289,7 @@ endif()
# Only enable unit testing if assertions are enabled. Otherwise, unit tests
# that expect AssertionException to be thrown will fail.
if(NOT ENABLE_ASSERTIONS)
+ message(WARNING "Disabling unit tests since assertions are disabled.")
set(ENABLE_UNIT_TESTING OFF)
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback