summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2021-03-03 18:59:43 +0100
committerGitHub <noreply@github.com>2021-03-03 17:59:43 +0000
commit81cf94dc266f41d7fa10098154fcb233a20d9f43 (patch)
treef892b420903e0d8b891654eff8dfd40256d452e0 /CMakeLists.txt
parent8144381611d2c3dcdcf56bcd343690abe98f9d5e (diff)
Remove obsolete gcc check. (#6041)
This PR removes a cmake check for gcc 4.5.1. As this version is more than a decade old and would not work anyway, as it does not fully support C++11, not to mention C++17.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 060753864..7cb4e6291 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -350,24 +350,6 @@ endif()
enable_testing()
#-----------------------------------------------------------------------------#
-# Check GCC version.
-#
-# GCC version 4.5.1 builds MiniSat incorrectly with -O2, which results in
-# incorrect answers.
-
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
- execute_process(
- COMMAND ${CMAKE_CXX_COMPILER} -dumpversion
- OUTPUT_VARIABLE GCC_VERSION
- OUTPUT_STRIP_TRAILING_WHITESPACE)
- if(GCC_VERSION VERSION_EQUAL "4.5.1")
- message(FATAL_ERROR
- "GCC 4.5.1's optimizer is known to build MiniSat incorrectly "
- "(and by extension CVC4).")
- endif()
-endif()
-
-#-----------------------------------------------------------------------------#
# Check options, find packages and configure build.
if(USE_PYTHON2)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback