summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-09-29 22:55:33 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-29 22:58:53 -0700
commit464470c311de4d26b59a2f4ddca6960c3161997a (patch)
tree0836f1e4dca99d3715e6f88ef16fc070588bd8a2 /CMakeLists.txt
parent80c89d9d221218b35d2eaf7ba69144ecfe9e8abd (diff)
cmake: Ignore ctest exit code for coverage reports.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 86007b39a..4f17db83b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -269,10 +269,15 @@ if(ENABLE_COVERAGE)
include(CodeCoverage)
APPEND_COVERAGE_COMPILER_FLAGS()
add_definitions(-DCVC4_COVERAGE)
+ # Note: The ctest command returns a non-zero exit code if tests fail or run
+ # into a timeout. As a consequence, the coverage report is not generated. To
+ # prevent this we always return with exit code 0 after the ctest command has
+ # finished.
setup_target_for_coverage_lcov(
NAME coverage
EXECUTABLE
- ctest -j${CTEST_NTHREADS} -LE "example" --output-on-failure $(ARGS))
+ ctest -j${CTEST_NTHREADS} -LE "example"
+ --output-on-failure $(ARGS) || exit 0)
endif()
if(ENABLE_DEBUG_CONTEXT_MM)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback