summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-09-22 02:02:01 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commitf16ee492e0a4cff5b83649f72a54af49054a2b37 (patch)
tree862b25ef6dc76510e479b8aced9f6096e1f6411f /CMakeLists.txt
parenteada65a37e18bea23e3cbf584f47f72859cc69f9 (diff)
cmake: Add python3 option.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad6adf2e0..b097a70d7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,6 +79,7 @@ option(USE_CRYPTOMINISAT "Use CryptoMiniSat SAT solver")
option(USE_LFSC "Use LFSC proof checker")
option(USE_SYMFPU "Use SymFPU for floating point support")
option(USE_PYTHON2 "Prefer using Python 2 (for Python bindings)")
+option(USE_PYTHON3 "Prefer using Python 3 (for Python bindings)")
# Custom install directories for dependencies
# If no directory is provided by the user, we first check if the dependency was
@@ -217,8 +218,9 @@ enable_testing()
if(USE_PYTHON2)
find_package(PythonInterp 2.7 REQUIRED)
+elseif(USE_PYTHON3)
+ find_package(PythonInterp 3 REQUIRED)
else()
- find_package(PythonInterp 3)
find_package(PythonInterp REQUIRED)
endif()
@@ -459,6 +461,7 @@ print_config("Shared libs :" ENABLE_SHARED)
print_config("Java bindings :" BUILD_BINDINGS_JAVA)
print_config("Python bindings :" BUILD_BINDINGS_PYTHON)
print_config("Python2 :" USE_PYTHON2)
+print_config("Python3 :" USE_PYTHON3)
message("")
print_config("Portfolio :" ENABLE_PORTFOLIO)
message("")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback