summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <nafur42@gmail.com>2021-09-28 20:10:45 -0700
committerGitHub <noreply@github.com>2021-09-29 03:10:45 +0000
commita42b56e46f579b57eb0a3f49d1195881670375e7 (patch)
tree5a9f033cf8492768ed47c4ca6d0832f8bb43e6ea /CMakeLists.txt
parent1c1add20d0842ea347fffb19bb3ad90eee665a3b (diff)
remove stuff (#7258)
This PR removes the BUILD_LIB_ONLY cmake option, and the associated --lib-only configure script option. If you only want the library, just run make cvc5 instead of make.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e2e24ecf1..054d4938c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -146,9 +146,6 @@ set(PROGRAM_PREFIX "" CACHE STRING "Program prefix on make install")
option(BUILD_BINDINGS_PYTHON "Build Python bindings based on new C++ API ")
option(BUILD_BINDINGS_JAVA "Build Java bindings based on new C++ API ")
-# Build limitations
-option(BUILD_LIB_ONLY "Only build the library")
-
# Api documentation
cvc5_option(BUILD_DOCS "Build Api documentation")
@@ -678,8 +675,6 @@ print_config("GLPK " ${USE_GLPK})
print_config("Kissat " ${USE_KISSAT} FOUND_SYSTEM ${Kissat_FOUND_SYSTEM})
print_config("LibPoly " ${USE_POLY} FOUND_SYSTEM ${Poly_FOUND_SYSTEM})
print_config("CoCoALib " ${USE_COCOA} FOUND_SYSTEM ${CoCoA_FOUND_SYSTEM})
-message("")
-print_config("Build libcvc5 only " ${BUILD_LIB_ONLY})
if(CVC5_USE_CLN_IMP)
print_config("MP library " "cln" FOUND_SYSTEM ${CLN_FOUND_SYSTEM})
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback