summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2020-08-04 14:03:36 -0700
committerGitHub <noreply@github.com>2020-08-04 16:03:36 -0500
commit99640a4dc014177ed3b205b7186254933e7c5566 (patch)
treeac3dd4516f681d22574b7af86c0d1a222b8a2f91 /CMakeLists.txt
parent24a40040a4a5f88f96eada87e46323ace729f06a (diff)
Add documentation and build instructions for recompilation (LGPL). (#4844)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 93ea5cbeb..2d658ee31 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -548,7 +548,11 @@ endif()
# Generate CVC4's cvc4autoconfig.h header
include(ConfigureCVC4)
+if(NOT ENABLE_SHARED)
+ set(CVC4_STATIC_BUILD ON)
+endif()
configure_file(cvc4autoconfig.h.in cvc4autoconfig.h)
+unset(CVC4_STATIC_BUILD)
include_directories(${CMAKE_CURRENT_BINARY_DIR})
#-----------------------------------------------------------------------------#
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback