summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2021-03-04 20:03:24 +0100
committerGitHub <noreply@github.com>2021-03-04 19:03:24 +0000
commitb0ab269c2039051a16212d5c9e7276c5f5c20b1d (patch)
tree561c2e177a84aa78667f24c50378e046a1733706 /CMakeLists.txt
parent0942d5af032a2e58bd455df6e8b585f245a43dc9 (diff)
Add cmake scripts for iwyu targets. (#6042)
This PR adds some utility targets that simplify the usage of iwyu (include-what-you-use) on our code base.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7cb4e6291..7ac2eb262 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -536,6 +536,11 @@ if(GPL_LIBS)
endif()
#-----------------------------------------------------------------------------#
+# Provide targets to inspect iwyu suggestions
+
+include(IWYU)
+
+#-----------------------------------------------------------------------------#
# Generate CVC4's cvc4autoconfig.h header
include(ConfigureCVC4)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback