summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2021-04-07 12:15:31 -0700
committerGitHub <noreply@github.com>2021-04-07 19:15:31 +0000
commit887a75715761767bb7fd7b1d71e188399a4edd3b (patch)
treeaf6e47920d9443915ba8a97d12c7607a3ca7759c /CMakeLists.txt
parent04a494e251a8cc2c90bb429e2858f1c4eb8f88ff (diff)
New C++ Api: Initial setup of Api documentation. (#6295)
This configures the initial setup for generating Api documentation with Sphinx via Breathe and Doxygen. All fixes in the documentation of the cvc5.h header are for the purpose of eliminating warnings. This PR does not check for completeness of the documentation, and does not yet tweak the documentation to be nice, beautiful and consistent, which is postponed to future PRs. Configure with `--docs`, and then make. This will generate a `docs` directory in the build directory. The Sphinx documentation can be found at `build/docs/sphinx/index.html`. Doxygen documentation is only generated as xml under `build/docs/doxygen`. This PR further proposes a new style for copyright headers. If this style is approved, I will submit a PR to update the update_copyright.pl script.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c6909d216..8b2928961 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -135,13 +135,16 @@ set(GLPK_DIR "" CACHE STRING "Set GLPK install directory")
# Prepend binaries with prefix on make install
set(PROGRAM_PREFIX "" CACHE STRING "Program prefix on make install")
-# Supprted language bindings based on new C++ API
+# Supported language bindings based on new C++ API
option(BUILD_BINDINGS_PYTHON "Build Python bindings based on new C++ API ")
option(BUILD_BINDINGS_JAVA "Build Java bindings based on new C++ API ")
# Build limitations
option(BUILD_LIB_ONLY "Only build the library")
+# Api documentation
+cvc4_option(BUILD_DOCS "Build Api documentation")
+
#-----------------------------------------------------------------------------#
# Internal cmake variables
@@ -511,6 +514,10 @@ if(BUILD_BINDINGS_JAVA)
message(WARNING "Java API is currently under development.")
endif()
+if(BUILD_DOCS)
+ add_subdirectory(docs)
+endif()
+
#-----------------------------------------------------------------------------#
# Package configuration
#
@@ -659,6 +666,8 @@ endif()
print_config("Editline " ${USE_EDITLINE})
print_config("SymFPU " ${USE_SYMFPU})
message("")
+print_config("Api docs " ${BUILD_DOCS})
+message("")
if(ABC_DIR)
print_config("ABC dir " ${ABC_DIR})
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback