summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-10-10 20:48:44 -0700
committerGitHub <noreply@github.com>2018-10-10 20:48:44 -0700
commit0da5ede58934b3a30944e32835698e84626f4c0a (patch)
treea0b5d8338dfb02aa9fd0e978daccc0dc5df8e04a /CMakeLists.txt
parent960dfe7f894e57d3e8b7ca13867d212e982ff68d (diff)
cmake: Use gcovr instead lcov for coverage report generation. (#2617)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 435407fea..62a7a7ea0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -280,7 +280,7 @@ if(ENABLE_COVERAGE)
# into a timeout. As a consequence, the coverage report is not generated. To
# prevent this we always return with exit code 0 after the ctest command has
# finished.
- setup_target_for_coverage_lcov(
+ setup_target_for_coverage_gcovr_html(
NAME coverage
EXECUTABLE
ctest -j${CTEST_NTHREADS} -LE "example"
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback