summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndres Noetzli <andres.noetzli@gmail.com>2020-03-09 13:15:34 -0700
committerGitHub <noreply@github.com>2020-03-09 15:15:34 -0500
commit3740873b8b1ac7e1f2c203b26de6dd1a0ef73f43 (patch)
tree04561b1bc01f544c4376000198c6a422606a69af /CMakeLists.txt
parente337310b9f5df6b7ecd0f2e351b9c0e4265e8e69 (diff)
Increase stack size for Windows builds to 100 MB (#3943)
Fixes #3528. The default stack size for Windows builds is very limited (it seems to be 1 MB). This leads to problems for some of our users' benchmarks (see the previously mentioned issue and another email that we've received recently). Bumping the stack size to 100 MB seems to solve the issues for the benchmarks that we have received. This of course does not mean that we shouldn't continue working towards making less of our code recursive.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 885577260..945f71d36 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,6 +243,10 @@ add_check_c_cxx_flag("-Wshadow")
# cdlist.h warnings. Remove when fixed.
add_check_cxx_flag("-Wno-class-memaccess")
+if (WIN32)
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--stack,100000000")
+endif ()
+
#-----------------------------------------------------------------------------#
# Use ld.gold if available
@@ -670,6 +674,7 @@ message("")
message("CPPLAGS (-D...) : ${CVC4_DEFINITIONS}")
message("CXXFLAGS : ${CMAKE_CXX_FLAGS}")
message("CFLAGS : ${CMAKE_C_FLAGS}")
+message("Linker flags : ${CMAKE_EXE_LINKER_FLAGS}")
message("")
message("Install prefix : ${CMAKE_INSTALL_PREFIX}")
message("")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback