summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-09-21 23:26:56 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commiteada65a37e18bea23e3cbf584f47f72859cc69f9 (patch)
treeb18a10c8291b9a25e693835d190c83614d71b450 /CMakeLists.txt
parent79263ff809ee9e5766199bbd63b79449fc8fa3d0 (diff)
cmake: Enable -Wall.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b733b65d1..ad6adf2e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -148,11 +148,16 @@ include(Config${CMAKE_BUILD_TYPE})
# Compiler flags
add_check_c_cxx_flag("-O${OPTIMIZATION_LEVEL}")
+add_check_c_cxx_flag("-Wall")
add_check_c_flag("-fexceptions")
add_check_c_cxx_flag("-Wno-deprecated")
add_check_cxx_flag("-Wsuggest-override")
add_check_cxx_flag("-Wnon-virtual-dtor")
+# Temporarily disable -Wclass-memaccess to suppress 'no trivial copy-assignment'
+# cdlist.h warnings. Remove when fixed.
+add_check_cxx_flag("-Wno-class-memaccess")
+
#-----------------------------------------------------------------------------#
# Option defaults (three-valued options (cvc4_option(...)))
#
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback