summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormudathirmahgoub <mudathirmahgoub@gmail.com>2021-03-20 05:23:44 -0500
committerGitHub <noreply@github.com>2021-03-20 05:23:44 -0500
commita374f7b577b48908d623cf7b64594f1c98cfb8b7 (patch)
tree0173b96f4f9ec3c967b3d7d9cf64ed4c1c555d8f /CMakeLists.txt
parentbdc92b3bb257134c01c5e4818e97f71cbb66ab52 (diff)
Generate cvc/Kind.java for the java API (#6143)
PR changes: Refactor python/genkinds.py by separating parsing from file generation. Add java/genkinds.py to generate file Kind.java. Enable java API in ./configure.sh with "under development" warning.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 843fc16c1..1bbe6d288 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -565,8 +565,8 @@ if(BUILD_BINDINGS_PYTHON)
endif()
if(BUILD_BINDINGS_JAVA)
- message(FATAL_ERROR
- "Java bindings for the new API are not implemented yet.")
+ add_subdirectory(src/api/java)
+ message(WARNING "Java API is currently under development.")
endif()
#-----------------------------------------------------------------------------#
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback