summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndres Noetzli <andres.noetzli@gmail.com>2020-07-02 17:14:22 -0700
committerGitHub <noreply@github.com>2020-07-02 17:14:22 -0700
commit2faf908ed88c798a25b4881e3ce3026dc139bca3 (patch)
treea0e0977d8c40e4c4e6f9aa36f517335062ee282b /CMakeLists.txt
parent34661cedac9ea64c4cec5fc71f0d303eb7688723 (diff)
Remove SWIG bindings (#4683)
This commit removes support for SWIG bindings for the legacy API. The bindings were already broken by 19054b3b1d427e662d30d4322df2b2f2361353da and we are not planning on using SWIG for the Java API for the new API.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 7 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b6027b46..688a7c1ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -165,12 +165,9 @@ set(SYMFPU_DIR "" CACHE STRING "Set SymFPU install directory")
# Prepend binaries with prefix on make install
set(PROGRAM_PREFIX "" CACHE STRING "Program prefix on make install")
-# Supported SWIG language bindings
-option(BUILD_SWIG_BINDINGS_JAVA "Build Java bindings with SWIG")
-option(BUILD_SWIG_BINDINGS_PYTHON "Build Python bindings with SWIG")
-
# Supprted language bindings based on new C++ API
option(BUILD_BINDINGS_PYTHON "Build Python bindings based on new C++ API ")
+option(BUILD_BINDINGS_JAVA "Build Java bindings based on new C++ API ")
#-----------------------------------------------------------------------------#
# Internal cmake variables
@@ -542,14 +539,15 @@ add_subdirectory(doc)
add_subdirectory(src)
add_subdirectory(test)
-if(BUILD_SWIG_BINDINGS_JAVA OR BUILD_SWIG_BINDINGS_PYTHON)
- add_subdirectory(src/bindings)
-endif()
-
if(BUILD_BINDINGS_PYTHON)
add_subdirectory(src/api/python)
endif()
+if(BUILD_BINDINGS_JAVA)
+ message(FATAL_ERROR
+ "Java bindings for the new API are not implemented yet.")
+endif()
+
#-----------------------------------------------------------------------------#
# Package configuration
#
@@ -624,9 +622,8 @@ print_config("Valgrind :" ENABLE_VALGRIND)
message("")
print_config("Shared libs :" ENABLE_SHARED)
print_config("Static binary :" ENABLE_STATIC_BINARY)
-print_config("Java SWIG bindings :" BUILD_SWIG_BINDINGS_JAVA)
-print_config("Python SWIG bindings :" BUILD_SWIG_BINDINGS_PYTHON)
print_config("Python bindings :" BUILD_BINDINGS_PYTHON)
+print_config("Java bindings :" BUILD_BINDINGS_JAVA)
print_config("Python2 :" USE_PYTHON2)
print_config("Python3 :" USE_PYTHON3)
message("")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback