summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-09-15 00:03:27 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commita8c0ae49ee9c04327b1a8d538a0cdae746616d5b (patch)
treeeb242b3977b56e83bfcc6099d5f666d7ea1a7a4b /CMakeLists.txt
parent01c979407390b88641aaf6fbd0307fd6d10a8dcb (diff)
cmake: Disable unit tests if assertions are not enabled.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 23a52db59..69f990903 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -228,6 +228,9 @@ if(ENABLE_ASSERTIONS)
add_definitions(-DCVC4_ASSERTIONS)
else()
add_definitions(-DNDEBUG)
+ # Only enable unit testing if assertions are enabled. Otherwise, unit tests
+ # that expect AssertionException to be thrown will fail.
+ set(ENABLE_UNIT_TESTING OFF)
endif()
if(ENABLE_COVERAGE)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback