summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-08-17 18:11:26 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit1ca4a5cc3697d5df15ed18c07531b349625866f8 (patch)
treeb485dbc15733a2094a20516fb154ab1303d88dc1 /CMakeLists.txt
parentb812d3303748704d5582a16a5d095d03955fe900 (diff)
cmake: Add portfolio support.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 204e10169..8e5957768 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -138,6 +138,7 @@ cvc4_option(ENABLE_DEBUG_SYMBOLS "Enable debug symbols")
cvc4_option(ENABLE_DUMPING "Enable dumpin")
cvc4_option(ENABLE_MUZZLE "Enable silencing CVC4; supress ALL non-result output")
cvc4_option(ENABLE_OPTIMIZED "Enable optimization")
+cvc4_option(ENABLE_PORTFOLIO "Enable portfolio support")
cvc4_option(ENABLE_PROOFS "Enable proof support")
cvc4_option(ENABLE_REPLAY "Enable the replay feature")
cvc4_option(ENABLE_STATISTICS "Enable statistics")
@@ -259,6 +260,17 @@ if(ENABLE_MUZZLE)
add_definitions(-DCVC4_MUZZLE)
endif()
+if(ENABLE_PORTFOLIO)
+ find_package(Boost REQUIRED COMPONENTS thread)
+ set(USE_CLN OFF)
+ set(THREADS_PREFER_PTHREAD_FLAG ON)
+ find_package(Threads REQUIRED)
+ if(THREADS_HAVE_PTHREAD_ARG)
+ add_c_cxx_flag(-pthread)
+ endif()
+ add_definitions(-DCVC4_PORTFOLIO)
+endif()
+
if(ENABLE_PROFILING)
add_definitions(-DCVC4_PROFILING)
add_check_c_cxx_flag("-pg")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback