summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-08-24 23:14:32 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit7be6be7dec00579cb7eaae32bed1217d6c35ee83 (patch)
tree27ea1d88cb613b0d508588969958b1e1e808327b /CMakeLists.txt
parent0b4926e10f7788f209bbc515e13d1884a8590bb4 (diff)
cmake: Add module finder for GLPK-cut-log.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a2f8ed8a..3e0d394e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -156,6 +156,7 @@ option(USE_ABC "Use ABC for AIG bit-blasting")
option(USE_CADICAL "Use CaDiCaL SAT solver")
option(USE_CLN "Use CLN instead of GMP")
option(USE_CRYPTOMINISAT "Use CryptoMiniSat SAT solver")
+option(USE_GLPK "Use GLPK simplex solver")
option(USE_LFSC "Use LFSC proof checker")
option(USE_READLINE "Use readline for better interactive support")
option(USE_SYMFPU "Use SymFPU for floating point support")
@@ -356,11 +357,6 @@ endif()
if(USE_CLN)
set(GPL_LIBS "${GPL_LIBS} cln")
- if(NOT ENABLE_GPL)
- message(FATAL_ERROR
- "Bad configuration detected: BSD-licensed code only, but also requested "
- "GPLed libraries: ${GPL_LIBS}")
- endif()
find_package(CLN 1.2.2 REQUIRED)
cvc4_link_library(${CLN_LIBRARIES})
include_directories(${CLN_INCLUDE_DIR})
@@ -384,6 +380,14 @@ if(USE_CRYPTOMINISAT)
add_definitions(-DCVC4_USE_CRYPTOMINISAT)
endif()
+if(USE_GLPK)
+ set(GPL_LIBS "${GPL_LIBS} glpk")
+ find_package(GLPK REQUIRED)
+ cvc4_link_library(${GLPK_LIBRARIES})
+ include_directories(${GLPK_INCLUDE_DIR})
+ add_definitions(-DCVC4_USE_GLPK)
+endif()
+
if(USE_LFSC)
set(RUN_REGRESSION_ARGS ${RUN_REGRESSION_ARGS} --with-lfsc)
find_package(LFSC REQUIRED)
@@ -588,7 +592,7 @@ message("")
message("ABC : ${USE_ABC}")
message("CaDiCaL : ${USE_CADICAL}")
message("Cryptominisat : ${USE_CRYPTOMINISAT}")
-#message("GLPK : ${USE_GLPK}")
+message("GLPK : ${USE_GLPK}")
message("LFSC : ${USE_LFSC}")
#message("MP library : ${mplibrary}")
message("Readline : ${USE_READLINE}")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback