summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2021-03-27 10:41:49 +0100
committerGitHub <noreply@github.com>2021-03-27 09:41:49 +0000
commit4b7e392eca42f89d103c5eb74157a44d4b40fe4b (patch)
tree649e24b292ac6b6dba11fe4a0e5df69ab4406019 /CMakeLists.txt
parent1ac0ebabb80f68c6c666d1eae1588c0950a6f2f7 (diff)
Refactor ANTLR3 dependency (#6202)
This PR refactors our first, and arguably most fragile, dependency. Right now all dependencies need to be manually installed (by calling the appropriate contrib/get-X script). For optional dependencies, we additionally need to enable them when calling the configure script (or via ccmake). This PR is the first step in refactoring all dependencies to be automatically build (if required) as an external project. Note that this not only eliminates the need to call contrib scripts, but also simplifies cross compilation: as all dependencies are now built within the build folders, every build folder has its own copy which may use different toolchains.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cd89b6c8a..7148a007c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,9 +61,6 @@ endif()
if(ABC_DIR)
list(APPEND CMAKE_PREFIX_PATH "${ABC_DIR}")
endif()
-if(ANTLR_DIR)
- list(APPEND CMAKE_PREFIX_PATH "${ANTLR_DIR}")
-endif()
if(CADICAL_DIR)
list(APPEND CMAKE_PREFIX_PATH "${CADICAL_DIR}")
endif()
@@ -151,7 +148,6 @@ option(USE_PYTHON2 "Force Python 2 (deprecated)")
# check the intalled system version. If the user provides a directory we
# immediately fail if the dependency was not found at the specified location.
set(ABC_DIR "" CACHE STRING "Set ABC install directory")
-set(ANTLR_DIR "" CACHE STRING "Set ANTLR3 install directory")
set(CADICAL_DIR "" CACHE STRING "Set CaDiCaL install directory")
set(CRYPTOMINISAT_DIR "" CACHE STRING "Set CryptoMiniSat install directory")
set(GLPK_DIR "" CACHE STRING "Set GLPK install directory")
@@ -691,9 +687,6 @@ message("")
if(ABC_DIR)
print_config("ABC dir " ${ABC_DIR})
endif()
-if(ANTLR_DIR)
- print_config("ANTLR dir " ${ANTLR_DIR})
-endif()
if(CADICAL_DIR)
print_config("CADICAL dir " ${CADICAL_DIR})
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback