summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2021-02-09 15:18:14 -0800
committerGitHub <noreply@github.com>2021-02-09 17:18:14 -0600
commit1d140d9fb1b79a1776f359c879667180e094de5a (patch)
treebc7d8509de90dd71fd63c8d0cf58294f0d6b6cce /CMakeLists.txt
parentfb6acf659fbf69327f8044e35e6919c1243bc848 (diff)
cmake: Make Python3 default and improve toml error messages. (#5884)
./configure.sh will now fail if Python3 is not installed on the system. Since Python2 is now deprecated the user has to explicitly enable it via --python2. This commit also removes the --python3 configure flag.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6c3ed4bbc..4a90afa8b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -152,8 +152,7 @@ option(USE_DRAT2ER "Include drat2er for making eager BV proofs")
option(USE_LFSC "Use LFSC proof checker")
option(USE_POLY "Use LibPoly for polynomial arithmetic")
option(USE_SYMFPU "Use SymFPU for floating point support")
-option(USE_PYTHON2 "Prefer using Python 2 (for Python bindings)")
-option(USE_PYTHON3 "Prefer using Python 3 (for Python bindings)")
+option(USE_PYTHON2 "Force Python 2 (deprecated)")
# Custom install directories for dependencies
# If no directory is provided by the user, we first check if the dependency was
@@ -376,10 +375,8 @@ endif()
if(USE_PYTHON2)
find_package(PythonInterp 2.7 REQUIRED)
-elseif(USE_PYTHON3)
- find_package(PythonInterp 3 REQUIRED)
else()
- find_package(PythonInterp REQUIRED)
+ find_package(PythonInterp 3 REQUIRED)
endif()
find_package(GMP REQUIRED)
@@ -715,7 +712,6 @@ print_config("Static binary :" ENABLE_STATIC_BINARY)
print_config("Python bindings :" BUILD_BINDINGS_PYTHON)
print_config("Java bindings :" BUILD_BINDINGS_JAVA)
print_config("Python2 :" USE_PYTHON2)
-print_config("Python3 :" USE_PYTHON3)
message("")
print_config("ABC :" USE_ABC)
print_config("CaDiCaL :" USE_CADICAL)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback