summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2018-08-16 18:56:03 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit107a5ec2da13a459794acb2d1d9b96dec724156c (patch)
treea5faf0c90a8e46dc45642e4cfabd3bb8d52f2c2e /CMakeLists.txt
parent3b308863cc79e853175be573a636190d2407601c (diff)
cmake: Add support for CxxTest.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt36
1 files changed, 26 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7f1adc0d..a2f0ac3d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,13 +112,13 @@ macro(cvc4_link_library library)
endmacro()
macro(cvc4_option var description)
- set(${var} AUTO CACHE STRING "${description}")
+ set(${var} IGNORE CACHE STRING "${description}")
# Provide drop down menu options in cmake-gui
- set_property(CACHE ${var} PROPERTY STRINGS AUTO ON OFF)
+ set_property(CACHE ${var} PROPERTY STRINGS IGNORE ON OFF)
endmacro()
macro(cvc4_set_option var value)
- if(${var} STREQUAL "AUTO")
+ if(${var} STREQUAL "IGNORE")
set(${var} ${value})
endif()
endmacro()
@@ -130,7 +130,7 @@ endmacro()
option(ENABLE_GPL "Enable GPL dependencies" OFF)
# General build options
-# >> 3-valued: AUTO ON OFF, allows to detect if set by user
+# >> 3-valued: INGORE ON OFF, allows to detect if set by user
# this is only necessary for options set for build types!
cvc4_option(ENABLE_ASSERTIONS "Enable assertions")
cvc4_option(ENABLE_DEBUG_SYMBOLS "Enable debug symbols")
@@ -139,8 +139,9 @@ cvc4_option(ENABLE_MUZZLE "Enable silencing CVC4; supress ALL non-result
cvc4_option(ENABLE_OPTIMIZED "Enable optimization")
cvc4_option(ENABLE_PROOFS "Enable proof support")
cvc4_option(ENABLE_REPLAY "Enable the replay feature")
-cvc4_option(ENABLE_TRACING "Enable tracing")
cvc4_option(ENABLE_STATISTICS "Enable statistics")
+cvc4_option(ENABLE_TRACING "Enable tracing")
+cvc4_option(ENABLE_UNIT_TESTING "Enable unit testing")
cvc4_option(ENABLE_VALGRIND "Enable valgrind instrumentation")
cvc4_option(ENABLE_SHARED "Build as shared library")
# >> 2-valued: ON OFF, for options where we don't need to detect if set by user
@@ -197,7 +198,7 @@ add_check_cxx_flag("-Wnon-virtual-dtor")
# Build types
if(NOT CMAKE_BUILD_TYPE)
- set(CMAKE_BUILD_TYPE production CACHE STRING "Options are: ${BUILD_TYPES}" FORCE)
+ set(CMAKE_BUILD_TYPE Production CACHE STRING "Options are: ${BUILD_TYPES}" FORCE)
# Provide drop down menu options in cmake-gui
set_property(CACHE CMAKE_BUILD_TYPE PROPERTY STRINGS ${BUILD_TYPES})
endif()
@@ -264,6 +265,11 @@ if(ENABLE_TRACING)
set(CVC4_TRACING 1)
endif()
+if(ENABLE_UNIT_TESTING)
+ find_package(CxxTest REQUIRED)
+ enable_testing()
+endif()
+
if(ENABLE_SHARED)
set(BUILD_SHARED_LIBS ON)
endif()
@@ -454,6 +460,12 @@ include_directories(${CMAKE_CURRENT_BINARY_DIR})
add_subdirectory(doc)
add_subdirectory(src)
+add_subdirectory(test/java)
+add_subdirectory(test/regress)
+add_subdirectory(test/system)
+if(ENABLE_UNIT_TESTING)
+ add_subdirectory(test/unit)
+endif()
if(ENABLE_PROOFS)
add_subdirectory(proofs/signatures)
@@ -486,12 +498,16 @@ message("Tracing : ${ENABLE_TRACING}")
message("Dumping : ${ENABLE_DUMPING}")
message("Muzzle : ${ENABLE_MUZZLE}")
message("")
-#message("Unit tests : ${support_unit_tests}")
-message("gcov support : ${ENABLE_COVERAGE}")
-message("gprof support : ${ENABLE_PROFILING}")
+message("Unit tests : ${ENABLE_UNIT_TESTING}")
+message("Coverage (gcov) : ${ENABLE_COVERAGE}")
+message("Profiling (gprof) : ${ENABLE_PROFILING}")
message("")
#message("Static libs : ${enable_static}")
-message("Shared libs : ${ENABLE_SHARED}")
+if(BUILD_SHARED_LIBS)
+ message("Shared libs : ON")
+else()
+ message("Shared libs : OFF")
+endif()
#message("Static binary: ${enable_static_binary}")
#message("Compat lib : ${CVC4_BUILD_LIBCOMPAT}")
#message("Bindings : ${bindings_to_be_built}")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback