summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-09-06 09:18:07 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit76bd881a535fa2969dfebbe96a62115e41ed223e (patch)
treea4f3912be83cb3c131f95ef80d5afdf8ab1cbc57 /CMakeLists.txt
parent2e931a009cc474a6c326fc9a1b1b289198a50838 (diff)
cmake: Add library versioning for libcvc4.so.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 264daa615..f46d3ce30 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,7 @@ project(cvc4)
# Major component of the version of CVC4.
set(CVC4_MAJOR 1)
# Minor component of the version of CVC4.
-set(CVC4_MINOR 6)
+set(CVC4_MINOR 7)
# Release component of the version of CVC4.
set(CVC4_RELEASE 0)
# Extraversion component of the version of CVC4.
@@ -23,6 +23,10 @@ endif()
# Define to the full name of this package.
set(PACKAGE_NAME "${PROJECT_NAME}")
+# Shared library versioning. Increment SOVERSION for every new CVC4 release.
+set(CVC4_VERSION "${CVC4_MAJOR}.${CVC4_MINOR}.${CVC4_RELEASE}")
+set(CVC4_SOVERSION 5)
+
#### These defines are only use in autotools make files, will likely be
#### replaced with corresponding CPack stuff
## Define to the full name and version of this package.
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback