summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2018-08-22 08:46:50 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit38c24575b3415f375b14ebfb7685a1621c7587e2 (patch)
tree9198192884d1f5062e38ae3f90efc8d771dd1e05 /CMakeLists.txt
parent6f219294f25cb675caeb5c846f201c22255b50c7 (diff)
cmake: Add dependencies for test targets and support for make coverage.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36c372652..74f223e22 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -255,7 +255,10 @@ if(ENABLE_COVERAGE)
include(CodeCoverage)
APPEND_COVERAGE_COMPILER_FLAGS()
add_definitions(-DCVC4_COVERAGE)
- # TODO set_up_target_for_coverage + regression tests
+ setup_target_for_coverage_lcov(
+ NAME coverage
+ EXECUTABLE ctest $(ARGS)
+ DEPENDENCIES cvc4-bin)
endif()
if(ENABLE_DUMPING)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback