summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-09-25 21:26:06 -0700
committerGitHub <noreply@github.com>2018-09-25 21:26:06 -0700
commit2069d956851667718c45353f41a3d4aa2b8e7c73 (patch)
tree425cae63fbd63a0080b133619dcefb605b2a0143 /CMakeLists.txt
parentd6fa6bb3fbe4d81d90d76140b6a4b210b36e91d7 (diff)
cmake: Exclude examples for coverage target. (#2535)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3eced0885..921396e21 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -270,7 +270,8 @@ if(ENABLE_COVERAGE)
add_definitions(-DCVC4_COVERAGE)
setup_target_for_coverage_lcov(
NAME coverage
- EXECUTABLE ctest -j${CTEST_NTHREADS} $(ARGS)
+ EXECUTABLE
+ ctest -j${CTEST_NTHREADS} -LE "example" --output-on-failure $(ARGS)
DEPENDENCIES cvc4-bin)
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback