summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2018-08-17 18:25:27 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commitdb75dee2b0644e141fd076769b5f46275c61dff3 (patch)
treebb6b3673713525388594cce75e7c8dc1eb3174ee /CMakeLists.txt
parent1ca4a5cc3697d5df15ed18c07531b349625866f8 (diff)
cmake: Added regression tests and target make regress.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e5957768..1ed87951d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -277,7 +277,7 @@ if(ENABLE_PROFILING)
endif()
if(ENABLE_PROOFS)
- #TODO RUN_REGRESSION_ARGS="${RUN_REGRESSION_ARGS:+$RUN_REGRESSION_ARGS }--enable-proof"
+ set(RUN_REGRESSION_ARGS ${RUN_REGRESSION_ARGS} --enable-proof)
add_definitions(-DCVC4_PROOF)
set(CVC4_PROOF 1)
endif()
@@ -350,6 +350,7 @@ if(USE_CRYPTOMINISAT)
endif()
if(USE_LFSC)
+ set(RUN_REGRESSION_ARGS ${RUN_REGRESSION_ARGS} --with-lfsc)
find_package(LFSC REQUIRED)
include_directories(${LFSC_INCLUDE_DIR})
add_definitions(-DCVC4_USE_LFSC)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback