summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2018-08-16 15:55:25 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit3b308863cc79e853175be573a636190d2407601c (patch)
treed9cc9869f545226c9c11876203720ad38f1b7b88 /CMakeLists.txt
parente8471288c0062d9e887d559a7c6f934bc85ea5ba (diff)
cmake: Filter through and disable unused HAVE_* variables from autotools.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt64
1 files changed, 32 insertions, 32 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a3f406154..a7f1adc0d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -142,10 +142,10 @@ cvc4_option(ENABLE_REPLAY "Enable the replay feature")
cvc4_option(ENABLE_TRACING "Enable tracing")
cvc4_option(ENABLE_STATISTICS "Enable statistics")
cvc4_option(ENABLE_VALGRIND "Enable valgrind instrumentation")
+cvc4_option(ENABLE_SHARED "Build as shared library")
# >> 2-valued: ON OFF, for options where we don't need to detect if set by user
option(ENABLE_COVERAGE "Enable support for gcov coverage testing" OFF)
option(ENABLE_PROFILING "Enable support for gprof profiling" OFF)
-option(ENABLE_SHARED "Build as shared library" OFF)
# Optional dependencies
option(USE_CADICAL "Use CaDiCaL SAT solver")
@@ -385,59 +385,59 @@ set(BOOST_HAS_THREAD_ATTR 0)
set(CVC4_CLN_IMP ${CVC4_USE_CLN_IMP})
# Defined if using the GMP multi-precision arithmetic library.
set(CVC4_GMP_IMP ${CVC4_USE_GMP_IMP})
-# Defined if the requested minimum BOOST version is satisfied
-set(HAVE_BOOST 1)
-# Define to 1 if you have <boost/system/error_code.hpp>
-set(HAVE_BOOST_SYSTEM_ERROR_CODE_HPP 1)
-# Define to 1 if you have <boost/thread.hpp>
-set(HAVE_BOOST_THREAD_HPP 1)
+## Defined if the requested minimum BOOST version is satisfied
+#set(HAVE_BOOST 1)
+## Define to 1 if you have <boost/system/error_code.hpp>
+#set(HAVE_BOOST_SYSTEM_ERROR_CODE_HPP 1)
+## Define to 1 if you have <boost/thread.hpp>
+#set(HAVE_BOOST_THREAD_HPP 1)
# Defined to 1 if clock_gettime() is supported by the platform.
set(HAVE_CLOCK_GETTIME 1)
# define if the compiler supports basic C++11 syntax
set(HAVE_CXX11 1)
# Define to 1 if you have the declaration of `optreset', and to 0 if you don't.
set(HAVE_DECL_OPTRESET 0)
-# Define to 1 if you have the declaration of `strerror_r', and to 0 if you
-# don't.
-set(HAVE_DECL_STRERROR_R 1)
-# Define to 1 if you have the <dlfcn.h> header file.
-set(HAVE_DLFCN_H 1)
+## Define to 1 if you have the declaration of `strerror_r', and to 0 if you
+## don't.
+#set(HAVE_DECL_STRERROR_R 1)
+## Define to 1 if you have the <dlfcn.h> header file.
+#set(HAVE_DLFCN_H 1)
# Define to 1 if you have the <ext/stdio_filebuf.h> header file.
set(HAVE_EXT_STDIO_FILEBUF_H 1)
# Defined to 1 if ffs() is supported by the platform.
set(HAVE_FFS 1)
# Define to 1 if you have the <getopt.h> header file.
set(HAVE_GETOPT_H 1)
-# Define to 1 if you have the <inttypes.h> header file.
-set(HAVE_INTTYPES_H 1)
-# Define to 1 if you have the `gmp' library (-lgmp).
-set(HAVE_LIBGMP 1)
+## Define to 1 if you have the <inttypes.h> header file.
+#set(HAVE_INTTYPES_H 1)
+## Define to 1 if you have the `gmp' library (-lgmp).
+#set(HAVE_LIBGMP 1)
## Define to 1 if you have the `profiler' library (-lprofiler).
#set(HAVE_LIBPROFILER 0)
# Define to 1 to use libreadline
#set(HAVE_LIBREADLINE 0)
## Define to 1 if you have the `tcmalloc' library (-ltcmalloc).
#set(HAVE_LIBTCMALLOC 0)
-# Define to 1 if you have the <memory.h> header file.
-set(HAVE_MEMORY_H 1)
+## Define to 1 if you have the <memory.h> header file.
+#set(HAVE_MEMORY_H 1)
# Defined to 1 if sigaltstack() is supported by the platform.
set(HAVE_SIGALTSTACK 1)
-# Define to 1 if you have the <stdint.h> header file.
-set(HAVE_STDINT_H 1)
-# Define to 1 if you have the <stdlib.h> header file.
-set(HAVE_STDLIB_H 1)
+## Define to 1 if you have the <stdint.h> header file.
+#set(HAVE_STDINT_H 1)
+## Define to 1 if you have the <stdlib.h> header file.
+#set(HAVE_STDLIB_H 1)
# Define to 1 if you have the `strerror_r' function.
set(HAVE_STRERROR_R 1)
-# Define to 1 if you have the <strings.h> header file.
-set(HAVE_STRINGS_H 1)
-# Define to 1 if you have the <string.h> header file.
-set(HAVE_STRING_H 1)
+## Define to 1 if you have the <strings.h> header file.
+#set(HAVE_STRINGS_H 1)
+## Define to 1 if you have the <string.h> header file.
+#set(HAVE_STRING_H 1)
# Defined to 1 if strtok_r() is supported by the platform.
set(HAVE_STRTOK_R 1)
-# Define to 1 if you have the <sys/stat.h> header file.
-set(HAVE_SYS_STAT_H 1)
-# Define to 1 if you have the <sys/types.h> header file.
-set(HAVE_SYS_TYPES_H 1)
+## Define to 1 if you have the <sys/stat.h> header file.
+#set(HAVE_SYS_STAT_H 1)
+## Define to 1 if you have the <sys/types.h> header file.
+#set(HAVE_SYS_TYPES_H 1)
# Define to 1 if you have the <unistd.h> header file.
set(HAVE_UNISTD_H 1)
## Define to the sub-directory where libtool stores uninstalled libraries.
@@ -489,9 +489,9 @@ message("")
#message("Unit tests : ${support_unit_tests}")
message("gcov support : ${ENABLE_COVERAGE}")
message("gprof support : ${ENABLE_PROFILING}")
-#message("")
+message("")
#message("Static libs : ${enable_static}")
-#message("Shared libs : ${enable_shared}")
+message("Shared libs : ${ENABLE_SHARED}")
#message("Static binary: ${enable_static_binary}")
#message("Compat lib : ${CVC4_BUILD_LIBCOMPAT}")
#message("Bindings : ${bindings_to_be_built}")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback