summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Dierl <simon.dierl@cs.tu-dortmund.de>2019-12-20 00:51:29 +0100
committerAndres Noetzli <andres.noetzli@gmail.com>2019-12-19 15:51:29 -0800
commitf5ca3e5d09b457ac21b10793eb5d1efe3fbe40f6 (patch)
tree28e5c54de38ff924005c84800c6f3c56216fe898 /CMakeLists.txt
parentbc2b801ec4ad83e013c302e7608238feef386a8a (diff)
Define all options modified by ENABLE_BEST using cvc4_option (#3578)
Signed-off-by: Simon Dierl <simon.dierl@cs.tu-dortmund.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 11 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d8b6d9ab..1c187eff3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -142,19 +142,19 @@ option(ENABLE_PROFILING "Enable support for gprof profiling")
# >> 3-valued: IGNORE ON OFF
# > allows to detect if set by user (default: IGNORE)
# > only necessary for options set for ENABLE_BEST
-cvc4_option(USE_ABC "Use ABC for AIG bit-blasting")
-cvc4_option(USE_CLN "Use CLN instead of GMP")
-cvc4_option(USE_GLPK "Use GLPK simplex solver")
-cvc4_option(USE_READLINE "Use readline for better interactive support")
+cvc4_option(USE_ABC "Use ABC for AIG bit-blasting")
+cvc4_option(USE_CADICAL "Use CaDiCaL SAT solver")
+cvc4_option(USE_CLN "Use CLN instead of GMP")
+cvc4_option(USE_GLPK "Use GLPK simplex solver")
+cvc4_option(USE_CRYPTOMINISAT "Use CryptoMiniSat SAT solver")
+cvc4_option(USE_READLINE "Use readline for better interactive support")
# >> 2-valued: ON OFF
# > for options where we don't need to detect if set by user (default: OFF)
-option(USE_CADICAL "Use CaDiCaL SAT solver")
-option(USE_CRYPTOMINISAT "Use CryptoMiniSat SAT solver")
-option(USE_DRAT2ER "Include drat2er for making eager BV proofs")
-option(USE_LFSC "Use LFSC proof checker")
-option(USE_SYMFPU "Use SymFPU for floating point support")
-option(USE_PYTHON2 "Prefer using Python 2 (for Python bindings)")
-option(USE_PYTHON3 "Prefer using Python 3 (for Python bindings)")
+option(USE_DRAT2ER "Include drat2er for making eager BV proofs")
+option(USE_LFSC "Use LFSC proof checker")
+option(USE_SYMFPU "Use SymFPU for floating point support")
+option(USE_PYTHON2 "Prefer using Python 2 (for Python bindings)")
+option(USE_PYTHON3 "Prefer using Python 3 (for Python bindings)")
# Custom install directories for dependencies
# If no directory is provided by the user, we first check if the dependency was
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback