summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-08-13 14:03:54 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit013a0fb7fe918d707604690a96ef6c0559af7440 (patch)
tree41d7f3b19b4761ad4fb7d40880f0d974e97cfd1c /CMakeLists.txt
parent7c3f54f21acf99681c34ced71c8033bafb853052 (diff)
cmake: Add module finder for CLN.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 20 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 34281a5f2..9d5e4da54 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -102,13 +102,24 @@ message(STATUS "Building ${CMAKE_BUILD_TYPE} build")
#-----------------------------------------------------------------------------#
+option(USE_CLN "Use CLN instead of GMP" OFF)
+
+#-----------------------------------------------------------------------------#
+
find_package(PythonInterp REQUIRED)
find_package(GMP REQUIRED)
-message(STATUS "Found GMP headers: ${GMP_INCLUDE_DIR}")
set(LIBRARIES ${LIBRARIES} ${GMP_LIBRARIES})
include_directories(${GMP_INCLUDE_DIR})
+if(USE_CLN)
+ find_package(CLN 1.2.2 REQUIRED)
+ if(CLN_FOUND)
+ set(LIBRARIES ${LIBRARIES} ${GMP_LIBRARIES})
+ include_directories(${GMP_INCLUDE_DIR})
+ endif()
+endif()
+
find_package(ANTLR REQUIRED)
message(STATUS "Found ANTLR headers: ${ANTLR_INCLUDE_DIR}")
set(LIBRARIES ${LIBRARIES} ${ANTLR_LIBRARIES})
@@ -143,7 +154,7 @@ execute_process(
#-----------------------------------------------------------------------------#
-# CONFIGURATION (for now manual)
+include(ConfigureCVC4)
# Define to 1 if Boost threading library has support for thread attributes
set(BOOST_HAS_THREAD_ATTR 0)
@@ -221,11 +232,13 @@ set(STRERROR_R_CHAR_P 1)
configure_file(cvc4autoconfig.new.h.in cvc4autoconfig.h)
include_directories(${CMAKE_CURRENT_BINARY_DIR})
-# src/util/rational.h.in
-# src/util/integer.h.in
-set(CVC4_NEED_INT64_T_OVERLOADS 0)
-set(CVC4_USE_CLN_IMP 0)
-set(CVC4_USE_GMP_IMP 1)
+if(USE_CLN)
+ set(CVC4_USE_CLN_IMP 1)
+ set(CVC4_USE_GMP_IMP 0)
+else()
+ set(CVC4_USE_CLN_IMP 0)
+ set(CVC4_USE_GMP_IMP 1)
+endif()
set(CVC4_USE_SYMFPU 0)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback