summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2021-03-10 11:40:15 -0800
committerGitHub <noreply@github.com>2021-03-10 19:40:15 +0000
commit27fb04bc96999e101b45458c549345e864e085e9 (patch)
treedb3326985c464226c544c3b234ca772efa1854f9 /CMakeLists.txt
parent99acb6adc4858e9228a75283c0d4a640ce7cc812 (diff)
cmake: Fix optimization level for debug builds. (#6097)
Further cleans up some unused variables and moves the configuration of best to configure.sh.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 1 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f5100cd4..dc244917d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -271,16 +271,6 @@ else()
endif()
#-----------------------------------------------------------------------------#
-# Set options for best configuration
-
-if(ENABLE_BEST)
- cvc4_set_option(USE_ABC ON)
- cvc4_set_option(USE_CADICAL ON)
- cvc4_set_option(USE_CLN ON)
- cvc4_set_option(USE_CRYPTOMINISAT ON)
- cvc4_set_option(USE_GLPK ON)
- cvc4_set_option(USE_EDITLINE ON)
-endif()
# Only enable unit testing if assertions are enabled. Otherwise, unit tests
# that expect AssertionException to be thrown will fail.
@@ -671,7 +661,6 @@ endif()
message("")
print_config("GPL :" ENABLE_GPL)
print_config("Best configuration :" ENABLE_BEST)
-print_config("Optimization level :" OPTIMIZATION_LEVEL)
message("")
print_config("Assertions :" ENABLE_ASSERTIONS)
print_config("Debug symbols :" ENABLE_DEBUG_SYMBOLS)
@@ -706,7 +695,7 @@ print_config("Kissat :" USE_KISSAT)
print_config("LFSC :" USE_LFSC)
print_config("LibPoly :" USE_POLY)
message("")
-print_config("BUILD_LIB_ONLY :" BUILD_LIB_ONLY)
+print_config("Build libcvc4 only :" BUILD_LIB_ONLY)
if(CVC4_USE_CLN_IMP)
message("MP library : cln")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback